Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
311 Posts
Discussion Starter #1
I only experience that once a while, mostly when i start my car, it idles pretty bad, sometimes just stalled and sometimes get back to normal idle speed after i give some gas rev it up abit.

I also experience the situation that my engine dies after I released the gas pedal and tend to stop.

Some people tells me it's a possible vacuum leak, my experience tells me it's abd throttle body or TPS sensor... what you guys think?
 

·
Boost is my drug!
Joined
·
1,319 Posts
I also experience the situation that my engine dies after I released the gas pedal and tend to stop.
same thing is happening to me.. only when I high rev it or high boosting..

anytime i do that at low rpm or steady driving. its ok.


some say its ISC or IAC..,., I thought it was the TPS
 

·
Registered
Joined
·
311 Posts
Discussion Starter #4
isn't the engine light supposed to come on or flash when TPS sends an error code?
Anyways... I will see what i can do.
 

·
Boost is my drug!
Joined
·
1,319 Posts
ah I see!

I got NO CODES.. light flashed once! status = ok.

so i guess it must be the ISC or the IAC whats the diff anyways!?
 

·
Dr Wheelspin Rh.D.
Joined
·
4,393 Posts
isn't the engine light supposed to come on or flash when TPS sends an error code?
Anyways... I will see what i can do.
NO, ECU does NOT always turn on the check engine light when there is a code. In fact it rarely turns on the CEL when a code is stored.

If there are no codes the light will flash continuously every 1/2 seconds. If you get only one flash then you did something wrong while checking for codes.
 

·
stop pulling me over pigs
Joined
·
1,259 Posts
My NA does that once in a blue moon too - depending on gas, and external temperature. Its a toyota thing, has something to do with the cold start injector, there was a service bulletin. I just give it some gas, goes away after 5 secs, and i live my life :) lol

trust me my tps went, things way worse than what you're talking about start to happen......
 
G

·
Guest
Joined
·
0 Posts
when my afm went bad, the rpm would shoot up and then die at start up, sometimes it would start and then idle roughly and die short after, the car would also die when i did moderate breaking
 

·
Registered
Joined
·
311 Posts
Discussion Starter #12
it's true that my car will idle fine once i give a bit more gas let it rev over 2000rpm, then everything feels like normal.. my mechanic used abit Carb cleaner on last Friday when repairing my water hose and i worried it might be caused by the carb cleaner on the AFM.. is the damange repairable, or can i just wash theafm again with water to clean it up ? Thanks.
 
D

·
Guest
Joined
·
0 Posts
i have the same problem... car stalls when i don't break in gear... thought it was the tps aswell... but i know i got a vacuum leak which i gotta get fixed first...
 

·
Registered
Joined
·
311 Posts
Discussion Starter #14
the stalling problem never occrued again. Only experienced problem with idling sometimes... but I sometimes experience a rough throttle, when you try to accelerate in gear, you could feel the sudden jerking and it only kept jerking for a second then car revs up and acelerating like no tomorrow.. really don't knwo what's going on with mycar
 

·
stop pulling me over pigs
Joined
·
1,259 Posts
sounds like its electronic- which means FUN for you.... ;)

hit up the tps, diagnose that first then go from there

-you could always go to the junkyard and swap one, just see if it fixes your problem, shouldnt run you much
 
1 - 15 of 15 Posts
Top