Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
Is their a test that can be done to see if my valve seals need to be replaced? Im pretty positive it is them because of the symptoms. When the car sits overnight and I start it in the morning it blows blue smoke for about 10 seconds. Also, if my car is idling for awhile and I rev the motor I get blue smoke for a few seconds as well. Thanks for any help
 

·
powered by
Joined
·
998 Posts
it is your valve seals. all toyotas have this problem, some worse than others. Many times it is the first thing to show up when a engine is "sludged" but I believe the supras just have a problem due to the higher exhaust temps.
 

·
Registered
Joined
·
87 Posts
Discussion Starter #3
What is the worst thing that can happen if I dont get this fixed right away and would a bad valve seal cause any loss in performance. Thanks a lot guys for your repsonses
 
A

·
Guest
Joined
·
0 Posts
KJSUPRA said:
What is the worst thing that can happen if I dont get this fixed right away and would a bad valve seal cause any loss in performance. Thanks a lot guys for your repsonses
Nothing really. Just the annoying (and somewhat embarassing) smoke and your plugs will need to be changed more frequently (maybe every 10,000 miles instead of every 20,000).

I have the same problem, but not as bad. It only does it if the car has been off for a extended period of time (overnight). The cloud clears almost immediately. I plan to do cams, springs, and retainers and will change the seals at the same time.
 
1 - 6 of 6 Posts
Top