Supra Forums banner

1 - 2 of 2 Posts

·
Passion Driven
Joined
·
1,689 Posts
Discussion Starter #1
Hey fella's.

So I was able to verify (with my OCD powers in keeping receipts and history on Microsoft Money) that I did in fact buy a Thermostat straight from Acura in October of last year, since my Integra was not warming up (stuck open) correctly. It fixed the problem!

Then I had an issue of a coolant leak. I replaced the radiator and found that was only part of the issue. I replaced the upper rad hose but it was cut too short and now the leak is very slight because its not pushed up 100% (about 80%).

So. Considering I've replaced the Thermostat, Radiator, and did a Coolant flush.....Now in the heat my car's temp needle rises above normal if I sit still long enough! The fans do kick on, but it still rises. Hasn't risen to H at all yet, just towards it, and I usually move again before it could. It moves back down very quickly if I move maybe 5ft (first gear). So it's very sensitive. It only goes above normal (Needle rests at 40%) if I am sitting still for more than 3-5 literal minutes.

Could my very slow/minor leak cause a not-so-great pressurized coolant system thereby weakening its effect? Does the fact that my overflow tank stay above Max after I turn the car off present an issue? The car also had a recent (~20k miles) water pump replacement. There seems to be nothing left to freshen or replace coolant wise. Could my newer Acura T-stat be stuck closed? Already!?



Nonetheless- I have my original upper rad hose (that actually is fine) which I'm going to fit on and secure and see if stopping that leak will do it. But otherwise, what the hey-in-a-hootinani?!

:wavey:
 

·
Registered
Joined
·
396 Posts
Might have air in the system, check to make sure your coolant is a mix of 50/50 distilled water and coolant and flush/burp the system.
 
1 - 2 of 2 Posts
Top