Supra Forums banner

1 - 8 of 8 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I am using VPC/GCC with a VPC harness, and the units don't light up when I turn the ignition key on to ACC. Harness plugs look nice and flush together, how can I check whats going on? TIA
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
souds like a bad connection test the wires to make sure you have good contack !..what did you use to connect the wires t taps or did you just splice and wrap the wires????
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I didn't splice anything, using HKS VPC harness to connect both units (they piggy-back off eachother). Not sure if I have to splice power/ground separately, but my guess is not. I'll try checking wires to see if there is enough juice for them to run.
 

·
Banned
Joined
·
945 Posts
MONSTER said:
I didn't splice anything, using HKS VPC harness to connect both units (they piggy-back off eachother). Not sure if I have to splice power/ground separately, but my guess is not. I'll try checking wires to see if there is enough juice for them to run.
Does the car turn over? Normally when the VPC/GCC don't light (at least in my experience) they aren't working.
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #5
The car turns over, but slowly. I think battery is weak. I've ditched the VPC harness last night, and hardwired it, and both units still dont illuminate. I've used multimeter probe to see if there is any power in lines going to the VPC, nothing. It looks like my ECU is not getting power. Car turns over, starter clicks and spins the crank. Weird.....any ideas?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Wolf,
Check all fuses/relays (esp in the engine compartment).
Do the pumps turn on when you put the key on?
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
ditto sound like a blown fuse some where also check the fuses under the hood!
Stage7 said:
Wolf,
Check all fuses/relays (esp in the engine compartment).
Do the pumps turn on when you put the key on?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Pumps turn on, I have them running directly off battery, via 30Amp Bosch relay. I will check all fuses....how do I check relays? I have carefully connected all ground points, all harenss connectors, and have left unused connectors taped up and tucked away, so I am almost sure there is no wire damage.

I will try and check if injectors are working properly (clicking), and also if plugs are sparking.....HKS Twin Power red light works properly.

I was told that VPC/GCC are very dim, even when they light up.....i'll try checking to see if they illuminate in the dark as well.
 
1 - 8 of 8 Posts
Top