Supra Forums banner
1 - 3 of 3 Posts

·
Wholesome creamy goodness
Joined
·
663 Posts
Discussion Starter · #1 ·
Hey Guys,
I just got my car back from the body shop and now I seem to be having problems. Well first of all, yesterday, the check engine light came on twice. Both times I reset the ECU thinking the ECU was freaking out considering my Supra's a 97 with the OBDII ECU. So far it hasn't come back on. However, I just got back and from a little joy ride but in the process, it died on my twice...both times when I came to a stop at a stop light. I don't have a aftermarket BOV so it's not that. I'm not quite sure if there is something wrong with the VPC. I had the car baking in the sun all day so that it'll help cure the new paint on the car, so I'm not sure if it's due to that, but in either case it's bugging the crap out of me. Please let me know if anyone has a clue to what's going on and how I may fix it. Thanks...Darshana S...
 

·
Wholesome creamy goodness
Joined
·
663 Posts
Discussion Starter · #3 ·
Keller,
Thanks for the advise...I do have the harness so I'll see if the harness is the cause of the problem. I was starting to wonder, do you think it could be do to the spark plugs?? I currently have the NGK 3330's...the car dies after letting off the throttle and sometimes while idling so I'm thinking the gap is too small (around 0.035 currently) or it's about time I changed the plugs. Plus there's that little fact that we in CA are stuck with crappy 91 Octane fuel, but I don't think that's that big of a factor...Darshana S...
 

·
Wholesome creamy goodness
Joined
·
663 Posts
Discussion Starter · #6 ·
The reason I keep reseting the ECU is because the freaken Check Engine Light keeps comming on. This is my main concern because this did not happen before when I changed my plugs and this is the reason that I suspect that there is something amiss with the VPC.

In regards to my VPC settings, it was dyno tuned by UPRD about 4 months ago. The fine tuning is being taken care of by SAFC. The current settings on the VPC are:
Response: +2 Clicks
Gain: -2 Clicks
Idle: +5 Clicks

Yesterday I added another click the gain, so now its -1 on the Gain and so far the car has been running fine and no check engine light. I guess we'll see in a day or two if that cured the problem or not...Darshana S...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top