Supra Forums banner
1 - 20 of 26 Posts

·
I have auto ADD.
Joined
·
4,567 Posts
Discussion Starter · #1 ·





I fixed the parking brake today so I'm finally able to park it in my driveway. Which also means I was able to wash it. Definately looks a bit less piece of shitish, although it still looks pretty bad up close. This was probably the first time it's been washed in over a year.

New exhaust and new clutch and I'll be in bidnezz. :gaysex:
 

·
BMM
Joined
·
2,329 Posts
looks good!

what exhaust are you looking at?
 

·
I have auto ADD.
Joined
·
4,567 Posts
Discussion Starter · #4 ·
Fuzz420 said:
excellent, now make it a habbit
lol i've only had it running for about a month. i haven't been able to wash it because my driveway is steep and my ebrake hasn't worked until today. it's also not registered and i haven't really been driving it.


boostedmkiii: i think i'm going to get the tanabe hyper medallion, i want something quiet.
 

·
Registered
Joined
·
5,728 Posts
do you have a stock exhaust you want to get rid of? i want a stock exhaust! i'll even trade my megan N1 knockoff 3" cat back for it
 

·
I have auto ADD.
Joined
·
4,567 Posts
Discussion Starter · #7 ·
Thermactor said:
do you have a stock exhaust you want to get rid of? i want a stock exhaust! i'll even trade my megan N1 knockoff 3" cat back for it
well i have the stock piping, but a different muffler was welded on at some point. it's pretty rusty and i don't know if i could seperate it to ship. it's also at my friends house about 150 miles away.

but if you're still interested in it i could go check it out, i still need to drive up there to get my bumper i left.
 

·
Registered
Joined
·
5,110 Posts
Put your mudflap on, the car looks nekkid!

I also gave my car the first good wash it's had in three and a half years just the other day. I had to use meguiar's scratch X on almost the entire car to get all the crap out/off of my white paint. Keep up the good work!
 

·
Registered
Joined
·
249 Posts
really like the last pic :bigthumb:
 

·
what would jesus drift?
Joined
·
987 Posts
that last pic now looks hella tight.

good job, glad you washed her,

my car is still dirty, but i have washed her liek 3 times in a little over a month of driving in good weather..

i keep seeming to get this black dust all over the rear of my car and bumper...
 

·
Banned
Joined
·
531 Posts
what was up with your ebrake..?

and how did you fix it..?


i pulled up on my ebrake a few days ago, parking normally, and CLICK, it loses tension and no longer locks...

so i have to leave it in 1st wherever i park...
 

·
I have auto ADD.
Joined
·
4,567 Posts
Discussion Starter · #15 ·
I just tightened the cable where it attached to the ebrake handle. It's one bolt on the side of the handle towards the console. Tighten it until you can only pull the handle up 5-8 clicks.
 

·
I have auto ADD.
Joined
·
4,567 Posts
Discussion Starter · #18 ·
i have a pair of mudflaps but they're black. i'm going to paint them before i put them back on, which will be in like a week or so.
 

·
Registered
Joined
·
357 Posts
brewster said:
i have a pair of mudflaps but they're black. i'm going to paint them before i put them back on, which will be in like a week or so.
Looking good brewster will be looking even better when you do that.
 
1 - 20 of 26 Posts
Top