Supra Forums banner

1 - 12 of 12 Posts

·
BARRA-51
Joined
·
505 Posts
Discussion Starter #1
Hey guys im posting for my friend. he just recently got a 94 NA and for some reason his car is making a really obnoxious sound at idle, we thoguth first it woud be the fan cluctch so we replaced it and guees was it wasnt. But for some reason whe he presses on the clutch it goes away weird huh!!!!!!! so im thinking it has to do with something related to the clutch plz help guys as i dont know what it is. later guys

Sergio,
 

·
Registered
Joined
·
259 Posts
i have the same problem- 10000000 people have told me it's the throw out bearing. I should fix it.
 

·
Banned
Joined
·
1,533 Posts
yeap, throwout bearing....

Do any of the supras have crankwalk problems when the bearing goes bad??
 

·
Over Medicated
Joined
·
2,718 Posts
bobmarley said:
I have the same problem.. my throwout bearing.. what causes it.. how do you fix it?
THey wear out, plain and simple. You can try and lube the clutch fork really well that will make the noise go away for a little while but replacing it is really the only way to fix it. If your going to go to the trouble of pulling the tranny for that you might as well put in a new clutch andd flywheel while everything is apart. My $0.02:)
 

·
Registered
Joined
·
593 Posts
your all wrong,... its the throw-out bearing-
morons-
 
S

·
Guest
Joined
·
0 Posts
please do not listen to these idiots.. they dont know what they are saying im telling you now its your throwout bearing
 
1 - 12 of 12 Posts
Top