Supra Forums banner

1 - 8 of 8 Posts

·
road hazard
Joined
·
452 Posts
Discussion Starter #1
just the other night, i headed to my car after work. started the engine and idled for a little to warm it up. then i get these weird symptoms. the car shook a little like it was struggling to stay at idle. normally, the car idles at ~1200-1300 RPMs in park and ~650 RPMs in drive. as the random shaking continued, i looked at my RPMs and every time the little shake occurred, my RPMs would drop a little and then struggle back to normal. also, i checked under the hood and all was fine. the shaking seemed to come from my exhaust system (i have a greddy sp). as if it was puffing out air (kinda like puff puff puff...puff puff...puff puff puff). just warm air, no black smoke or anything like that kind.

i just drove it off and see if it would go away. the car seemed to run fine and all...even from stop light to stop light. but when i got home and let the car idle for 5 min or so, the car would act up again.

i figured i was a little low on fuel since my fuel guage had about 2 gallons or so left. tonight, i filled the tank up (octane 91...damn nazi-cali) and i still have these symptons.

anyone have any idea what could be causing these symptoms? thanks.
 

·
Registered
Joined
·
532 Posts
i would guess get some kinda of fuel injection cleaner...maybe something like a fuel addative, maybe do it twice, after each fill up....also are u running cheap gas?? i hope not, get the big name brand like texaco or something. otherwise, i have no idea what it is, i can pretty much promise you that if this persists, get it fixed as it will probably get worse down the road. later
kevin
 

·
road hazard
Joined
·
452 Posts
Discussion Starter #3
thanks for replying. i only fill my car with mobil (octane 91, highest octane available in my area). i've been filling at the same mobil for over a year. whats strange is the problem just started occuring yesterday.
 

·
Registered
Joined
·
2,299 Posts
Mine has always idled like that. 1200 prms blum blum blum 650-700 then goes back 1200. sorta sounds like its camed..... But no joke it has done that for 3 years. or 36K miles.
 
S

·
Guest
Joined
·
0 Posts
Mine doesn't sount as pronounced as you describe, but it does have a slightly rough idle. Try some injector cleaner and change you plugs.
 
R

·
Guest
Joined
·
0 Posts
Haven't actually had this problem with My Supra but have something like that happen to my other car. It ended up being the EGR valve. I guess that it gets clogged and makes the car idle very rough. My car would even stall when I would stop at a light.

Jeff K
 

·
Administrator
Joined
·
4,970 Posts
Billy,

Check your IAC (Idle Air Control) Valve and EGR. If you don't have a good mechanic call mine, I known them for close to 10 years and they specialize in Japanese cars. They've worked on my Supra as well as a bunch of others.

Car X
John
714-547-8759
2015 N. Tustin Ave., Santa Ana (Between 17th and Santa Clara)

I'm sure he'd be happy to check your car out.
 
1 - 8 of 8 Posts
Top