Supra Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
my 95NA clocked a 100ks so had all the things done to it that it deserved. had tires changed, blitz nur spec r exhuast system, suspention done, timing belt, fan belt, and a full service where i used castrol edge oil (10w60), apparently its the best and oil filter... the whole 10 yards. after all done i feel the car has gone slower. the only things i think i screwed up on are either the spark plugs or the fuel filter. what i wanted to know is...

is it okay to use oil of that grade after so much mileage??

what are the right spark plugs? length, gap and heat range?
 

·
Registered
Joined
·
402 Posts
maybe you lost bottom end from exhaust change. maybe the oil is too thick can slow down moving parts if its like molasses. try maybe changing back to old exhaust so if it makes a difference if not put new back on . then on the next oil change try the reccomended 5-30 . 10 60 is really thick the new diesel trucks only run 15-40 process of elimination. good luck
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #9 ·
hey guys, been working on it, changed the spark plugs and it that brought it back to what i was expecting it to be... alls good now. thanks loads. havent dynod it or anything but think its added abit of bower... i mean the whole pakage. aint much so wont even bother. bout the oil... castrol just came up with this... yeah the weight does sound too much think should try the 5w40 one that they have. but the sales guy said and i directly qoute "• Deliver race proven power and
performance for highly tuned,
bad-to-the bone competition
• Provide strength in reserve when you're
pushing the limits
• Protect even when fast, hot or hard running
• Use fully synthetic technology to
beat the pants off conventional oil"

thanks for all.
 
1 - 9 of 9 Posts
Top