Supra Forums banner

4661 - 4680 of 4692 Posts

·
Registered
Joined
·
638 Posts
Just bought a Haltech Elite 2500 and Wideband during their Cyber sale - 15% off was too good. Not going to do anything until spring, but planning the harness etc. is now swamping my thoughts.
 

·
Kappa Check 1 2
Joined
·
691 Posts
Cleaned my garage in preparation for the holiday madness, still waiting on my rear end to get back from getting fully rebuilt out in Cali!

-Rich
 

·
Blue Thunder
Joined
·
3,474 Posts
Charged the dead battery. Damn mystery drainage !!! ARGH
 

·
From the land down under
Joined
·
3,854 Posts
If its left on, it is a thing.

Mystery drainage can be one of sooooo many things though. An alarm, a head-unit or any other aftermarket accessories wired incorrectly etc. Just a case of being methodical and going over everything one by one until you find the culprit
 

·
iSPOOL
Joined
·
1,138 Posts
My battery drainer is my door ajar sensor. I have to crack my window for it to read fully closed, if not it will read closed but after a minute it popped on. I have to adjust it soon because it's killed my battery many times.
 

·
handy with the steel
Joined
·
378 Posts
Started it for the first time in almost exactly a year.

Pulled my engine last December. Since then it has gotten upgraded:
- cams/springs/retainers
-single turbo (6767bb, phr street torque)
-IGN1As
-Motec M150
-custom engine wiring harness built by yours truly
-full radium fuel system w/walboro 450, ID1050x, flex fuel sensor


I was honestly shocked at how easily it started. I had some wiring mistakes on the TPS and flex fuel sensor, and I need EOL resistor for the LTC...but otherwise everything came in fine. After going through all of the sensor calibrations I disabled the fuel pumps and cranked it over several times to build oil pressure, then reenabled fuel pumps, held my breath, and turned the key. To my great surprise, it fired up Immediately. Like, one crank and VROOM.

Now I have to pull the harness back out and heat shrink the whole thing, then the fun part can begin: tuning and driving :cool:
 

·
Blue Thunder
Joined
·
3,474 Posts
If its left on, it is a thing.

Mystery drainage can be one of sooooo many things though. An alarm, a head-unit or any other aftermarket accessories wired incorrectly etc. Just a case of being methodical and going over everything one by one until you find the culprit
Pretty sure my drainage is my alarm. I don't have a dome light anymore. My SAFC NEO was/is there. It takes a few weeks siting to kill it though...the alarm goes off and that's how I know. LOL

B
 

·
Registered
Joined
·
51 Posts
So I got a silicone hose kit the other day (Click here for more info on the silicone hose kits) and spent a couple hours changing all the lines I could get my hands on without having to unbolt or remove anything. I re-used the original clamps where they had them, as for the smallest sized lines they fit super snug into the ports that they wont come off and don't need clamps.
I had a buddy weld in a bung for a wide-band O2 on my 3" Megan down-pipe. Ran the wiring right through a rubber grommet conveniently placed right next to the down-pipe and under the bottom of the passenger foot rug.
Bought a pack of Zener Diodes so I'll be wiring one in to remove my boost cut later today. All I have left to do is pick up a E-Boost Controller someone has locally and set it up.
 

·
The Great Beast 666
Joined
·
393 Posts
been a bit but finally bought rear 15inch welds, stock rear NA brakes, Mickey Thompson et streets. currently awaiting my chance to get a pair of OEM 17inchers for the front or some lightweight but reasonable front 17inchers that dont really offset the look of the welds. and some coil overs to help raise it all back up because currently my MKIV is too low for a drag setup.
 

·
Registered
Joined
·
25 Posts
Finished pulling the head for the NA-T build and dropped it off at my machinist. He will be cleaning, resurfacing, flow testing, and doing a full valve job on it. I also mocked up the front-mount and built brackets for it. Busy week.
 

·
iSPOOL
Joined
·
1,138 Posts
I changed my license plate because the new one sent to my house had "J29" on it. Hell to the nah.
248227
 

·
iSPOOL
Joined
·
1,138 Posts
I googled J29 and plenty of different info came up, so can you please explain why you didnt want it on your car? :)
Don't make me come down there.😎
248235
 
4661 - 4680 of 4692 Posts
Top