Supra Forums banner
1 - 18 of 18 Posts

·
200+mph
Joined
·
738 Posts
Discussion Starter · #1 · (Edited)
okey i don´t understand why this is happening. I have a 6 speed mkiv TT Supra and the toyota dealership just installed a new engine in it. It has been driven 3 k miles and then i noticed it was missfiring and i went with it to toyota and the told me that the tip of one spark plug had been melted and they have to take the engine out again and see if something else is damaged they think that atleast one piston has been destroyed.

My question is why is this happening because i have a greddy profec b boostcontroller but it was disconnected when the new engine was put in.

The boost never goes over 1.2 bar (17.4 psi) on 93 oct i do take 91 oct sometimes but i don´t give it much gas when i´m using 91 oct

*EDIT* okey I just talked to Toyota and they had to order a new Shortblock again !! this one only had 3 k miles. But they can´t seem to find out what is causing the knock
because it´s not overboosting and there is nothing wrong with the injectors...can something be wrong with the ECU ?

any ideas ???


I have the following mods

HKS Super dragger exhaust and dp
HKS FCD
Greddy Profe B boost controller
ARP Head Stud kit
Fidanza Racing Lightened Flywheel
Apex S-AFC II Special Edition( Not installed)
Titan Motorsports 2JZ-GTE Cam Gears
Stock platinum spark plugs ( could it be that they don´t handle the extra boost)
HKS Cone Air filter
Blitz Dual Turbo Timer
 

·
Registered
Joined
·
13,581 Posts
It could be more complicated, but for starters most, if not all, less than perfect ignition systems on Supras will misfire at boost much over 1 bar with stock plugs at stock gap. You should use a proper plug that is one heat range colder, I like NGK 6097's but the NGK 3330's are also widely used. Not to bust your chops while you're down, but this is one of the most basic things you should know about before cranking up the boost. Go to www.mkiv.com and read the faq section about spark plugs.
 

·
200+mph
Joined
·
738 Posts
Discussion Starter · #3 ·
I didn´t crank upp the boost. as i said the boost controller isn´t connected. the only think that is cranking upp the boost is tha Hks super dragger and downpipe
 

·
200+mph
Joined
·
738 Posts
Discussion Starter · #5 ·
Jason Rush said:
Did new injectors go in with the new engine? Could be as simple as a slightly clogged injector causing that cylinder to go lean.
No didn´t put new injectors but the car is only driven 50 k miles. I can´t seem to find NGK 6097´s(BKR7E) any where but i do own Greddy Iridium racing spark plugs intented for BPU supra´s and small single

If i am going to buy new injectors are the Blitz 850cc Injector good ? because they are cheap and you can drop them right in the oem fuel rail.
 

·
Registered
Joined
·
477 Posts
If they are going to pull the engine apart to look for more damage, I would at least have your current injectors flow tested. I learned this the hard way on my thinderbird. I burnt a hole in one piston. Pulled it out, replaced it and 2 weeks later the new piston had a hole in it. Had the injectors check and the one for that cylinder was clogged. It only takes one small speck of dirt to do this to you. Perhaps a small piece got past the filter or maybe something got into one of the lines during your engine installation. Who's to know? Best bet would be to have them flow tested. Even if you buy new injectors, would'nt you want to know for sure what caused your problem? I feel your pain, best of luck.
 

·
200+mph
Joined
·
738 Posts
Discussion Starter · #10 ·
okey I just talked to Toyota and they had to order a new Shortblock again !! this one only had 3 k miles. But they can´t seem to find out what is causing the knock

because it´s not overboosting and there is nothing wrong with the injectors...can something be wrong with the ECU ?


any ideas ???
 

·
ur moms favourite
Joined
·
1,404 Posts
SupraTT/Iceland said:
okey I just talked to Toyota and they had to order a new Shortblock again !! this one only had 3 k miles. But they can´t seem to find out what is causing the knock

because it´s not overboosting and there is nothing wrong with the injectors...can something be wrong with the ECU ?


any ideas ???
Ideas? Yep... Fuck toyota.

Seriously, you're average Toyota shop mechanic doesnt know shit from clay. If its not printed in one of their manuals, they dont know it, and they definitely dont have the initiative to actually problem solve.

Time to take your car to a reputable performance car specialist man, someone with real world experience on modified jap turbo vehicles.

Good luck

Gene
 

·
Banned
Joined
·
397 Posts
Toyota's idea of troubleshooting is randomly replacing parts until the problem goes away, never really finding out what happened or the true source of the problem, like a lot of OEMs. They just don't have time. Take the car to a shop.
 

·
200+mph
Joined
·
738 Posts
Discussion Starter · #15 ·
anybody else have any ideas ?
 

·
Registered
Joined
·
1,206 Posts
DTSupra30 said:
yea your problems started by by bringing it to toyota


Matt
+1

From what I've seen and heard, Toyota does some of the crappiest work of any shop out there. Best bet would be to take it to some place that actually cares about their reputation and your car to get the job done right. Good luck.
 

·
(overspooled)
Joined
·
2,836 Posts
which plug was melted? maybe boost isn't what you think....( move that injector around if you think its fine ;)
throw away your irridium plus too and get some 3330 or 6097...gap around .29...
 
1 - 18 of 18 Posts
Top