Supra Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
recently i have been having a problem in high rpms, at about 6k the car just dies boost drops all the way off and it sounds like the motor turned of if you wait a second and floor it again it will go back but some times it will do it again some times it wont and the problem isnt consistant sometimes it drives fine others it "dies" this hapens on half boost and full boost, so far im thinking fuel or electric related but what could this be?
 

·
Registered
Joined
·
1,254 Posts
check plugs & coils...
 

·
Registered
Joined
·
665 Posts
a damn lot. Ask mike when or if he did a tunèup on her. I don't remember helpinghim with it. I would do th tunèp on her its bêen over 2 years.PM me if you nêed help.
 

·
(overspooled)
Joined
·
2,836 Posts
PremiereBPU said:
recently i have been having a problem in high rpms, at about 6k the car just dies boost drops all the way off and it sounds like the motor turned of if you wait a second and floor it again it will go back but some times it will do it again some times it wont and the problem isnt consistant sometimes it drives fine others it "dies" this hapens on half boost and full boost, so far im thinking fuel or electric related but what could this be?
How much boost are you running? Sounds like bcc may need a little tuning.
Any chance you got a bad tank of gas? If you have an ebc try lowering your gain a little bit and see if that helps...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
well i have a update it i was wrong the whole car isnt shutting off i forced it to go when it was "dieing" the car still accelerates its just the turbos pretty much go offline ne suggestions with the new info FYI i have a fule cut defender i think greddy im bpu in ttc my boost gague is inacurate though its wrong even when the cars off it sits at -2 psi with the car off and a 12 psi vac at idle gets a 8 psi max at full boost
 

·
Registered
Joined
·
1,254 Posts
coils... if you're missing, you won't build boost...
 
1 - 9 of 9 Posts
Top