Supra Forums banner
1 - 19 of 19 Posts

·
two wheels is all i need
Joined
·
1,232 Posts
Discussion Starter · #1 ·
The car was running fine last nigth and today out of nowhere it started to boggle after 2.2k on 4th and 3k on 5th the car barely reachers 65mph now, i checked all the ic pipes, checked the distributor if any wires poped out checked the timing, the car started doing this this morning, i was driving with almoust no gas, i filled up a full tank of gas (50$ !!!!) and she was running fine untill i did one pull, after that it started doing it again. Any ideas would be great. Oh and in the morning the car came close to over heating a few times. Also sometimes when i start it up the heat temp just shoots straight up to about 75%,
 

·
Ludicrous speed! GO!
Joined
·
959 Posts
Let it cool down overnight and check the coolant to see if you are losing any.

Check for engine codes.

Are you an na-t? You mention ic pipes and distributor.
 

·
89 Turbo
Joined
·
380 Posts
koulee said:
Let it cool down overnight and check the coolant to see if you are losing any.

Check for engine codes.

Are you an na-t? You mention ic pipes and distributor.
^ His SN is TURBO.. ^Word... Check the coolant and burb it if you are low and


have to fill it up....
 

·
Acceleration
Joined
·
3,833 Posts
SupraTTurbo2JZ said:
Oh and in the morning the car came close to over heating a few times. Also sometimes when i start it up the heat temp just shoots straight up to about 75%,
Sounds like air in the cooling system. You need to burp the cooling system.
 

·
two wheels is all i need
Joined
·
1,232 Posts
Discussion Starter · #6 ·
UPDATE: The car starts to boggle every time i go over 2 psi.... in 1st, 2nd, and 3rd, 4th gear 1 psi and 5th starts to boggle in vaccum :(..... ill try to flush the cooling system today and see whats up. Problem is i dont know how ot flush it ? any tips ?


If that doesent work ill check the turbo and prey to god there is nothing wrong with it, maybe its just me but i can hear the spool ALOT more now.
 

·
two wheels is all i need
Joined
·
1,232 Posts
Discussion Starter · #8 ·
AGlobalThreat said:
http://supraforums.com/forum/showthread.php?t=351204&highlight=burp

:)

Are you positive you don't have a boost leak? Did you check wires?

Wires ? what wires... you mean IC pipes ? I checked them Twice. They are all on and lookin good. But than again i was just eyeballin it, one might have poped but i never had it above 5psi :( No ehxuast is just KILLIn me, the CT-26 is too small of a turbo to have no back pressure.


Thnx for the link
 

·
two wheels is all i need
Joined
·
1,232 Posts
Discussion Starter · #9 ·
The cooling system is "burbed" still same... I looked into a few things and remembered that i changed the sparkplugs from original wich had 160k miles on them to some no name brang not even turbo sparkplugs... only 5 of them the bad one was left in #1 cylinder, My car is running right like a mothafuker, i just witnessed 1/6th of my gas drop like it was nothing. So right now ill go get some new plugs and see what happens....
 

·
Ludicrous speed! GO!
Joined
·
959 Posts
djmesican said:
don't get platinums. and it's called "burping" :p

What should he get then? Iridiums? Coppers?

NGK or ND platinums oughta work.
 

·
Registered
Joined
·
1,317 Posts
I vote boost leak!

Have a friend drive behind you, if there is black smoke it's boost leak for sure. Bad gas mileage is also an indicator.
 

·
Registered
Joined
·
5,967 Posts
Boost leak. Check the accordian hose: It can rip at the bottom and hard to tell.

Check your O2 sensor plug. It may have come off / unplugged or the sensor just took a crap.

Check the AFM plug.
 

·
Registered
Joined
·
3,877 Posts
JDM Death said:
yo sash,its ur dip stick u fool
:rolleyes: if you're not going to help, don't post K thnx bye :rolleyes:



If you can hear it spool a lot louder, it is more than likely a boost leak. Tha ccoridan hose and the hose right off the turbo to the IC usually are the first to go because of the heat. If it's split right, you won't see it, but it will open once it starts boosting and you'll go rich...
 

·
two wheels is all i need
Joined
·
1,232 Posts
Discussion Starter · #17 ·
so how do i check if i have a leak somewhere.... I just put new plugs in there and it gave me a little bit more RPM before it starts to boggle but it still does that.
 

·
Ludicrous speed! GO!
Joined
·
959 Posts
The only real ways you can tell if you are boost leaking:

boost leak tester
take the hose off and inspect it visually
 

·
Registered
Joined
·
3,727 Posts
search!! for boost leak tester. im sure they put that thread in the FAQ section and it has pictures and everything how to make it.
just cuz you "looked" at your pipes doesnt mean anything.
 
1 - 19 of 19 Posts
Top