Supra Forums banner
1 - 20 of 20 Posts

·
Track Junkie
Joined
·
1,581 Posts
Discussion Starter · #1 ·
I posted this problem a while back, but didn't get much response.
Anyways, I got the torque converter rebuilt by Midwest, and installed 7200cc fuel system. now, the problem is still here, can't exceed 370rwhp. My Supra is making same exact horsepower with a GTE61p and GTE67P. According to Midwest, I don't need to lockup the converter and I should getting all the powers to the wheels.
The shop built my turbo kit did a compression test and no problem find. Transission was fairly new rebuilt by Boostlogic in July and car has not driven more than 200miles since then. I am currently using AEM v1.03 map, converted from v.94. Did I miss something in the AEM configuation? I am using GM3BAR sensor, GM IAT. Anyone has a SP67 or PTE67 auto map that can send me so I can take a look? I would be really appreciated if anyone can help me out.

Thanks in advance.

Chinchi
 

·
King of the NA-T's
Joined
·
4,044 Posts
Got a log file of your pulls? specifically ign timing, a/f ratio, boost, etc.
 

·
Registered
Joined
·
35 Posts
You were told you dont have to force the torque converter to lockup, esp. on the dyno..............doubt it...?


dc
 

·
Track Junkie
Joined
·
1,581 Posts
Discussion Starter · #5 ·
I think you misunderstand what I said. What I meant is even without lockup, I should get good amount of power on the road or on the dyno.
 
G

·
Who has done the work on your car? You should be able to make ~450rwhp atleast on pump gas with the converter unlocked. There is something very wrong.
 

·
How does my exhaust smell
Joined
·
1,002 Posts
I would bet the timing is too low (3-4 degrees at peak torque). You need to post up the logs so we can see. It would also help if you posted your current map.

I can post up my map for you (67GTQ, 850CC, BUILT AUTO), but we should probably see whats wrong with yours first.
 

·
Pays Cash, No Questions
Joined
·
2,306 Posts
Yes, please do post up your maps - as a previous AEM user, I would like to see what's going on...
 

·
Registered
Joined
·
807 Posts
post your map.... and the log.... be sure you monitor the transmission parameters, ignition parameters, and fuel paramters.

Justin
 

·
Track Junkie
Joined
·
1,581 Posts
Discussion Starter · #10 ·
trying to get the shop guy to send me the map and logs, but appearly he is too busy with his other customers. I'll post them up as soon as I got them. Also, he told me that it was running on 24 degree with 12 A/F ratio.
 

·
Bad Karma Supra
Joined
·
2,783 Posts
oohh - was the knock table logged by any chance too? 24deg @ 12:1 a/f...becareful man!u
 

·
King of the NA-T's
Joined
·
4,044 Posts
I don't have ver 1.03, so I didn't look at the cal file. The log file doesn't have your ign info on it, do you have a different log file with more engine parameters?
 

·
Track Junkie
Joined
·
1,581 Posts
Discussion Starter · #17 ·
Here is the old .94 version. Dan said his computer will lock up if logging too many files. I can ask him to log more if needed.

AEM v.94
 

·
Registered
Joined
·
807 Posts
have you done a compression test? the tranny looks to be fine, the convertor looks to holding the lock up. so it's go to be in the tuning. Tuning a "load down", or "reverse load" on the dyno to see what your drivetrain losses are.

Justin
 

·
King of the NA-T's
Joined
·
4,044 Posts
[email protected]!! Those are some aggressive timing maps! I hope you run race gas all the time! A log file with engine parameters would still be good, especially with knock data. I too would suggest doing a compression test.
 
1 - 20 of 20 Posts
Top