Supra Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
i have a question about where the timing should be.. today i checked my timing and it was at 16(or close) and i moved it back to 10 where i thought i had it.. but i went to take if for a test drive and from a stop i took off and then once it hit like 2500-3000 it felt liek it slowed down and then wehn it hit about 4000 it pulled hard all the way to aroudn 5500 where i shifted and left 2 nice 5 or so foot marks. haha :p but anyway before when it was set to 16 it pulled really hard from 3000 to 6000 but sometimes would hit fuel cut at .85 bar or like 11 psi which it never did before, so my question is where should it be? oh and also my car kinda back fires wehn im slowing down in lower rpms alot more now so is that from the timing being too de-advanced?
 
Joined
·
3,796 Posts
My guess would be that you set your timing too advanced and are detonating but your knock sensors are picking up on this and your ECU is retarding your timing. This explains the wacky powerbad. IIRC the timing should be around 12 degrees.

Nice rims BTW....
 

·
Premium Member
Joined
·
4,409 Posts
youre too advanced probably getting timing pulled by knock sensors below 3-4k rpm...

To reset timing, car must be warm, idling at 750 rpm and have the diagnostic box jumped... 10 degrees...try to set it again...

Ang
 

·
Registered
Joined
·
468 Posts
Discussion Starter #4
ok well ill go try and set it with the Dbox jumped, does it really make a diffrence? yeah it does feel like its retarding the timing, but how come its doing it once i turn it down? it didnt retard it when it was set higher,but i turn it down a little and now it does? and another thing.. do you think this could have anything to do with the face that i need to rewire my knock sensors? cause the damn engine light for knock sensors stays on and i ahvent got around to rewiring them yet.. but tehy havent worked since ive got the car like 4 months ago.. =O!

thx for the info :D
 

·
Premium Member
Joined
·
4,409 Posts
yes if youre getting a knock sensor code, your car will run like ass...
 
Joined
·
3,796 Posts
:stupid:
 

·
Registered
Joined
·
468 Posts
Discussion Starter #7
thats waht ive herd too, but the thing is.. is that my cars faster than my friends car and he doesnt have any codes, and hes running more boost than i am so i didnt think the knock sensors were really hurting anthing? what sighs would i get from them being bad?bad idle? or something along those lines.. or not being very fast? btw i just went out side and set it to 10deg.. and ran it,.. came back and checked my codes.. it gave me like 6 codes for runing to rich and running to lean and just dumb stuff. so i reset teh ecu, ran it at 16 deg timming and only the one code, 52 that ive always had..
 
Joined
·
3,796 Posts
You are faster because you're running unsafe timing advancement...
 

·
Registered
Joined
·
468 Posts
Discussion Starter #9
well if thats true, then how come when i set it to 10 deg, i got like 5 more codes then the one i had? some sum dumb ones like no afm signal, runiing to rich, running to lean, and how do you run to rich and to lean? ive orderd the new knock sensors from a buddy at toyota so im gonna put those on when ever they come in.. hopefully that solves alota ish
 
Joined
·
3,796 Posts
I dont know why you got all of those codes....try setting it to 10 or 12 again and reset the ecu and take her for a spin and then reset the ecu again.
 

·
Premium Member
Joined
·
4,409 Posts
well knock sensors cant detect knock past 3k, so if youre knock sensors are working, they wont pull timing after 3k, thats probably why youre faster, but youre probably detonating...

if youre getting a 52 though this shouldnt be an issue because your ecu would go into safe mode timing wise... and your car will not have as much power as it should
Ang
 
S

·
Guest
Joined
·
0 Posts
Whatawookie said:
10 degrees is the stock setting for 86-88. 12 is for 89-92.
It's 10 degrees for all years that I've seen.

Use the procedure in the manual, it's very simple, and without jumping the T-E1 connector you really have no idea what your timing is:
http://www.cygnusx1.net/supra/library/TSRM/ig/IG_20.html

Here is a good write-up on it. Of importance is that you do not get the code 51 during the test, or your timing won't be set properly:
http://www.cygnusx1.net/supra/techtip/setting_timing.html
 

·
Registered
Joined
·
468 Posts
Discussion Starter #14
ok soo wait.. whats the diffrence between the normal and the advance setting? also i checked it with te1 and e1 jumperd and with out it.. it was the same.
 
S

·
Guest
Joined
·
0 Posts
ippyness said:
ok soo wait.. whats the diffrence between the normal and the advance setting? also i checked it with te1 and e1 jumperd and with out it.. it was the same.
Was your check engine light flashing? Was it giving you a code, or just a fast flash for all normal?

http://www.cygnusx1.net/supra/library/TSRM/fi/FI_023.html

I'll hazzard to guess your TPS isn't adjusted properly and you'll get a code 51. You cannot set your timing untill you fix it, and therefore it doesn't matter if you jump the T-E1 as it won't hold the timing fixed.

Just a guess. :)
 

·
Registered
Joined
·
468 Posts
Discussion Starter #16
the only code i get, which ive always got like i said above, is 52 which im pretty sure becuse i need new knock sensors, but whats 51?
 

·
Registered
Joined
·
468 Posts
Discussion Starter #17
woo

wooo!! well today i decided to just rewire my knock sensors with a spare amp to guitar cable(shielded, multistrand ~50 ohm wire) and no more check engine light!!! :-D!!!! WOOO haha and! i set my timing back to 10 deg... and perfect! i was happy and jumping around and stuff.. haha also i got that stupid purple tint off my back windows..! ugh.. that was a major PITA!!well anyway thanks everyone for the help, and the motivation to do the knock sensors ;) im gonna just go get a new wiring harness one of these days.. now i needa figure out somethng else to do to my car.. ive done like everyting i can think of.. and i have to have something to work on everyday.. AH haha... later.. thx :)
 

·
Premium Member
Joined
·
4,409 Posts
Good job man!!! Have fun now, knock sensors can really make your car run like ass if theyre not working right
 
Joined
·
3,796 Posts
Nice!!
 
1 - 19 of 19 Posts
Top