Supra Forums banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Banned
Joined
·
754 Posts
Discussion Starter · #1 ·
One problem after another. My throw-out bearing went bad, so I repaired that at a shop and at the same time I installed a RPS Stage 3 clutch and RPS lightweight flywheel like 2 days ago. I dirve the car for around 100 miles or so and take it to a show last night which is another 40-50 miles. The car won the show . I start the car up to go back home, and I notice the clutch feel is a little mushy, but it comes back and it's strong again so I'm driving and I notice smoke from the engine bay. I pull over and I notice the car is leaking oil from the front of the engine. I get the car towed 80 miles back to my place and I have no money to fix it because I have put close to $8-9k in the past month in this car. What could it be. I never work on my cars, I usually take it to a shop. My friend helped me tow the car back home, and my other friend has a MK3 and he has always worked on his cars and he said he will help me out with it. for the first time I will be working on my car. I'm wondering what could the problem be. Maybe a front main seal? Crank walk?? There is oil on the timing belt, so that needs to be replaced. Any advice is appreciated. I am in need of help, so if you know something I shoudl watch out for, or how to do somethign better, etc... please let me know. Has anyone else had this problem???

~Farhad G.
 

·
Ludicrous speed! GO!
Joined
·
959 Posts
oil on the timing belt could probably mean that the cam gear oil seals are going.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top