Supra Forums banner

1 - 9 of 9 Posts

·
Newbie
Joined
·
11,221 Posts
Discussion Starter #1
Well hey anyways. I just installed a vpc, so now I can vent my BOV to the atmosphere. Anyways, when I rev up the car and the bov releases, instead of releasing from the hole, air comes out of the intake??

I was looking at the opening the whole time, and I don't see the "door" opens or anything, but yet I can hear that "whhooshh" sound. So I monitored it and lead it back to the intake, what's up with that?

GReddy RS bov.
 

·
Newbie
Joined
·
11,221 Posts
Discussion Starter #3
Yea I sold it, but bought it again, lol. It was giving me trouble before because I didn't have a vpc, but now I have a vpc.
 

·
95 Hardtopper X 2
Joined
·
1,709 Posts
If you just rev the car at idle there is hardly enough pressure for the blow-off valve to release air especially ones which are set to hard like my greedy, I guess thats why you hear it out the intake thats what I have always thought.
 

·
Newbie
Joined
·
11,221 Posts
Discussion Starter #5
So... I guess it's normal that the bov ain't open if I rev it in idle? Cause I mean, there's no way for me to check if it opens at wot (or is there)?
 

·
Registered
Joined
·
300 Posts
michaelvanle said:
So... I guess it's normal that the bov ain't open if I rev it in idle? Cause I mean, there's no way for me to check if it opens at wot (or is there)?
my hks bov doesnt open at idle either
 

·
Newbie
Joined
·
11,221 Posts
Discussion Starter #7
leett said:
my hks bov doesnt open at idle either
But do you still hear the "wwhhooshh" under the engine? Cause I swear I can hear the bov go off, and feel air COMING OUT of the intake.
 

·
2jz powered
Joined
·
1,649 Posts
you might hear a woosh from the bov slightly opening but theres no load on your engine at idle so its not making any boost which means the bov isn't opening all the way.
 

·
Newbie
Joined
·
11,221 Posts
Discussion Starter #9
SoarerTT said:
you might hear a woosh from the bov slightly opening but theres no load on your engine at idle so its not making any boost which means the bov isn't opening all the way.

I just noticed that it wasn't opening. I'm on a VPC now. Before when I wasn't on the VPC, that shit opens up (and my car stalled, that's why I sold it off).

In a nutshell, it used to open before I had a vpc, and now it doesn't (2 weeks later), so I don't know what's wrong (or if it's normal).
 
1 - 9 of 9 Posts
Top