Supra Forums banner
1 - 2 of 2 Posts

· Registered
Joined
·
6,381 Posts
Discussion Starter · #1 · (Edited)
Yessss Guys!!!.....finally.

After a major rebuild, everytime I drove my car around..20 miles or more, it would start heating.
Had every possible sensors and cooling system changed but to no avail. i had even had my radiator cleaned out as well......

A lot of people told me i had a blown HG, but I refused to believe that .....GUt feeling I guess. ...
finally, last week I gave in and went and bought a brand new radiator with a lifetime warranty for $135.00 only. Took my half an hour to change it out. Today i took my car on a long drive ....at approximately 80 mph all the way...then up and down some very steep hills......and guess what???

NO More heatinf whatsoever. The gauge points way down...

The moral of the story is....do not write off a heating problem as a BHG all the time. ..I save almost 1500 dollars since refused to believe jusat one mechanic..even three.....
Now I can go and upgrade my turbo, and buy the PHR ecu map.....Yessssssssssssssssss!!!!!!!!!!...

Thanking all you Supra forums guys and gals who had help me eliminate my problems. I got a lot of things that way I checked and eliminated my problem.
Thank you all once again.
 

· Registered
Joined
·
6,381 Posts
Discussion Starter · #6 ·
BoostMan03 said:
Hey man i'm glad to hear that, congratulations, yeah, i don't like to take the bhg as a reason for anything the first time around either. But cool man that's great to know, that's what these guys are here for, to help. Good luck man!

yeah bosstman. now I can actually drive my Supra to Sactown .....lol....
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top